Minimum PHP version 5.6 for Webasyst

Webasyst framework moves to minimum PHP version 5.6. The current minimum PHP version is 5.2.

If your online store is powered by Shop-Script 8, then you do not need to do anything, because you already have a correct PHP version enabled. You may skip reading this article.

What is it for and how to get prepared

It is necessary for you to be able to update Webasyst framework, and to install Webasyst apps and plugins and their updates. To do so, switch your web-hosting account to PHP version 5.6 or higher. If these versions are not available for choice, you will need to move to another hosting company.

When do I have to change the PHP version?

At any time when you should need to install an update which is otherwise unavailable because of a minimum PHP version requirement. It will not happen before October 1, 2019. Until that date you have the time to make this change in your account. However, the sooner you do so the better you will be prepared for future updates.

You may raise the PHP version whenever it is convenient for you. You may even never do so at all and continue working as usual. It will only mean that you will not be able to install software updates, but your website will keep working without updates anyway.

What will happen if I stay with PHP version below 5.6?

Nothing special—your website will continue operating as normal. The only thing that will change is that you will not be able to install updates. If you do not raise the PHP version, then you will only see that new updates are available in Installer but you will not have an option to install them.

May I use PHP version higher than 5.6?

Certainly you may. And it would be even better so! As of version 7.0, PHP works notably faster than previous versions.

Why moving to a higher PHP version at all?

To make the software development faster and our updates more useful. There is quite a number of PHP versions, and we need to spend our time to ensure that our apps work equally well with each of them. The less PHP versions we need to support, the faster the testing is performed and the sooner you receive a new update.

There is more thing—programmers feel more comfortable when working with newer PHP versions. By refusing to support old versions, we cease writing old-fashioned code, which is getting more and more difficult for younger developers to read and understand, including those among our partners. Software development becomes faster and brings more fun. When it's a pleasure to work, then you get better results, too.

Is there a chance that a PHP version upgrade might break something?

It is theoretically possible but actually very unlikely. All latest versions of the framework, apps, plugins, widgets, and design themes developed by Webasyst definitely support PHP 5.6 or higher—we have checked that.

Still, if you have not the latest versions of apps or plugins installed, or if you made changes to the source code, or if you had custom plugins developed for your online store, then it is strongly recommended to test your site with a higher PHP version before finally moving to it.

How do I correctly change the version?

To change the PHP version, use your web-hosting control panel or contact your hosting company’s support team.

Once you have done so, monitor your website’s operation for a while. Look if any error messages start appearing in server logs. If everything is fine, then try to switch higher to PHP 7.0, 7.1, or 7.2. This will also speed up your website.

Should selection of a higher PHP version cause errors, switch to a lower version. To ensure that no errors occur with the latest PHP version, install all available updates for Webasyst framework, Shop-Script, and other installed apps, plugins, widgets, and design themes.